Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenCL not working
12-05-2013, 03:42 AM
Post: #11
RE: OpenCL not working
I build the 32bits wings on my home computer with nvidia toolkit and get Opencl 1.1 libraries.

I build the 64bits wings on my laptop with Intel toolkit and thus get OpenCL 1.2 libraries,
which doesn't work currently with Nvidia drivers.

But it means I must build everything on Nvidia to get it to work on every card, which
means setup another 64b dev environment or that I must fix opencl
library to check version at runtime and load new functions if available.

Stem: It priorities gpu before cpu, you can see and manually change that in your preferences file.
It only uses one device, it's complex enough anyway and I do not want to duplicate the memory usage.
Reply
12-06-2013, 10:48 AM
Post: #12
RE: OpenCL not working
Hi dgud,

(12-05-2013 03:42 AM)dgud Wrote:  I build the 64bits wings on my laptop with Intel toolkit and thus get OpenCL 1.2 libraries,
which doesn't work currently with Nvidia drivers.
Strange that it worked on my setup with nVidia.
I just very recently changed back to AMD GPU (playing again with Luxrender openCL path), so cannot re-check at the moment.
Quote:Stem: It priorities gpu before cpu, you can see and manually change that in your preferences file.
I cannot find any settings for that in the wings Preferences. I also cannot see anything in the preferences txt file.
Where/how is the setting made?
Reply
12-06-2013, 11:30 AM (This post was last modified: 12-06-2013 11:32 AM by micheus.)
Post: #13
RE: OpenCL not working
(12-06-2013 10:48 AM)Stem Wrote:  I cannot find any settings for that in the wings Preferences. I also cannot see anything in the preferences txt file.
You should find this line:
{cl_type,gpu}
I didn't find it too. Looking in the sources code I found that it is read from preferences but never write to. Undecided
Reply
12-06-2013, 07:19 PM
Post: #14
RE: OpenCL not working
Oh thanks Micheus for correcting me, you will have to manually add it, cpu or gpu are the options.
Otherwise it chooses gpu if available.
Reply
12-25-2013, 06:20 AM
Post: #15
RE: OpenCL not working
FYI,

I changed back to nVidia GPU (playing again with Blender Cycles). OpenCL is still working fine for Wings 1.5.2 -64bit. So I presume that wings is using the CPU for openCL as I have drivers installed(for CPU openCL).
Reply
12-28-2013, 07:24 PM
Post: #16
RE: OpenCL not working
Some of the shaders seem to be behaving strangely.

For instance:

Vertex Normals Colors:

(I think it's using Vertex POSITION for colours instead of Vertex Normal DIRECTION)

Face Normals Colors:

(faces facing down Z axis are black instead of blue, but faces on inside of legs are blue)

Depth:

(It's doing whatever it wants.)

Spherical Ambient Occlusion:

(It's doing whatever it wants)

Spherical Harmonics:

(Spherical Harmonics 5/8/9, DO work, though. So does Toon shading/gooch/brick/environment/all others)

Intel Core I7 960
Running Windows 7 x64 Professional
Geforce 660Ti
Reply
08-12-2017, 08:19 PM
Post: #17
RE: OpenCL not working
Arise, old thread!

So I suddenly got a one time error message window about opencl not being available. Ever since then the openCL proxy level slider has been grayed out and set to 0 in the preferences menu. The console just says "OpenCL not available undef" and "using GPU shaders".

It came out of the blue and I really can't figure this out. I'm not sure if the recent windows 10 update has anything to do with it, but I think this error came before the update.

I'm using win 10 pro 64b, nvidia gtx970. problem occurs in wings 1.5.4 and 2.1.5, both 64.
Reply
08-12-2017, 09:00 PM
Post: #18
RE: OpenCL not working
@KrisBee Windows update might have installed new nvidia drivers without OpenCL component, update manually from nvidia site should solve that.
Reply
08-15-2017, 05:52 AM
Post: #19
RE: OpenCL not working
My graphics drivers had not been updated according to geforce experience. But I downloaded the latest drivers and problem fixed. Smile
Reply


Forum Jump:


User(s) browsing this thread: 1 Guest(s)